找回密码
雪球 门户 银行贷款 查看内容

【期货指标】【图】期货用指标

2021-2-22 21:04| 发布者: admin| 查看: 2| 评论: 0

摘要: 不知道这里有没有抄期货的指标高手,这是一个主图指标,在通达信中可用,但是我放到做期货的软件赢顺交易上,不显示上下影线。不得不请高手了,请把这公式改为赢顺的,谢谢了!!! {主题概念} Z1:=STRCAT(HYBLOCK,' ...
不知道这里有没有抄期货指标高手,这是一个主图指标,在通达信中可用,但是我放到做期货的软件赢顺交易上,不显示上下影线。不得不请高手了,请把这公式改为赢顺的,谢谢了!!!
{主题概念}
Z1:=STRCAT(HYBLOCK,'----');   
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);   
Z4:=STRCAT(Z3,'----');   
DRAWTEXT_FIX(1,0.00,0.06,0,'    【主题概念】:')COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.06,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0.07,0.24,0,EXTERNSTR(0,14))COLORYELLOW;
MA1:=EMA(C,12);
MA2:=EMA(C,50);
MA3:=EMA(C,34);
MA4:=EMA(C,7);
MA5:=EMA(C,20);
MA6:=EMA(C,10);
DIFF:=EMA(CLOSE,30)-EMA(CLOSE,120);
DEA:=EMA(DIFF,9);
M1:MA(CLOSE,5),COLORRED,LINETHICK;
M2:EMA(CLOSE,12),COLORRED,LINETHICK;
M3:EMA(CLOSE,50),COLORRED,LINETHICK;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
IF(M3 REF(M3,1),M3,DRAWNULL),COLORGREEN,LINETHICK;
STICKLINE(C =MA1 AND C =MA2 AND DIFF =DEA ,H ,L-0.01 ,0 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C MA1 AND C =MA2 AND DIFF DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C =MA2 AND DIFF DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C =MA2 AND DIFF DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C =MA2 AND DIFF DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C =MA2 AND DIFF DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C =MA2 AND DIFF =DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C =MA2 AND DIFF =DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C =MA1 AND C =MA2 AND DIFF DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C =MA2 AND DIFF DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,O ,C ,3 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C MA1 AND C MA2 AND DIFF =DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C MA2 AND DIFF =DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C MA2 AND DIFF =DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C MA2 AND DIFF =DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C MA1 AND C MA2 AND DIFF =DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C =MA1 AND C MA2 AND DIFF =DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C MA2 AND DIFF =DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C MA2 AND DIFF =DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C MA2 AND DIFF =DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C MA2 AND DIFF =DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C =MA1 AND C MA2 AND DIFF DEA ,H ,L-0.008 ,0 ,0 ),COLORMAGENTA;
STICKLINE(C =MA1 AND C MA2 AND DIFF DEA ,O ,C ,2.5 ,0 ),COLORMAGENTA;
STICKLINE(C =MA1 AND C MA2 AND DIFF DEA ,O ,C ,2 ,0 ),COLORMAGENTA;
STICKLINE(C =MA1 AND C MA2 AND DIFF DEA ,O ,C ,1 ,0 ),COLORMAGENTA;
STICKLINE(C =MA1 AND C MA2 AND DIFF DEA ,O ,C ,0 ,0 ),COLORMAGENTA;
EXP1:EMA(C,12),COLORWHITE;
EXP2:EMA(C,50),COLORYELLOW;
VOLUME:=MA(VOL,1)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,9),9);
EMVA:=MA(EMV,14);
BB:=EMV-EMVA;
BIAS :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIASMA :=MA(BIAS,6);
CC:=BIAS-BIASMA;{WWW.55188.COM}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DD:=(K+D+J)/3;
KK:=J-DD;
DIFF2:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA2:=EMA(DIFF2,9);
SS:=DIFF2-DEA2;
AA:=MA(BB+CC+KK+SS,1)*0.01;
DRAWTEXT(CROSS(AA,0),L*0.95,'B'),LINETHICK4,COLORWHITE,NODRAW;
DRAWTEXT(CROSS(0,AA),H*1.06,'S'),LINETHICK4,COLORGREEN,NODRAW; 相关标签: 期货日内最厉害的高手, 期货高手只做一个方向, 期货傻瓜式买卖指标, 期货简单有效的指标, 期货高手都是假的

鲜花

握手

雷人

路过

鸡蛋
雪球

Powered by Discuz! X3.4 © 2001-2012 Comsenz Inc. Designed by 999test.cn & 雪球

GMT+8, 2021-3-7 00:23 , Processed in 0.113789 second(s), 17 queries .

返回顶部