找回密码
雪球 门户 银行贷款 查看内容

【手机发邮件怎么加附件】【图】较全的指标添加资讯(指标附件)

2021-2-22 21:04| 发布者: admin| 查看: 4| 评论: 0

摘要: DRAWTEXTABS(2,5,'所属板块:'+BKNAME),COLORFF50FF,linethick1; 总股本:=FINANCE2(35)/1000000*100;流通盘:=FINANCE2(37)/1000000*100; DRAWTEXTABS(15,20,'总股本:'+NUMTOSTRN(总股本,2)+'亿'),LINETHICK1,COLORY ...
DRAWTEXTABS(2,5,'所属板块:'+BKNAME),COLORFF50FF,linethick1;
总股本:=FINANCE2(35)/1000000*100;流通盘:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(15,20,'总股本:'+NUMTOSTRN(总股本,2)+'亿'),LINETHICK1,COLORYELLOW;
DRAWTEXTABS(160,20,'流通盘:'+NUMTOSTRN(流通盘,2)+'亿'),LINETHICK1,COLORYELLOW;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
每股现金流:=FINANCE2(6);
主营收入同比:=FINANCE2(11); 
净利润同比增长:=FINANCE2(10);
每股未分配:=FINANCE2(8);
每股公积金:=FINANCE2(7);
资产负债率:=FINANCE2(20)/FINANCE2(14)*100;
每股市净率:=DYNAINFO(58);
DRAWTEXTABS(160,35,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLOR00FF00;
DRAWTEXTABS(160,50,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORYELLOW;
DRAWTEXTABS(160,65,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLOR00FF00;
DRAWTEXTABS(15,35,'每股经营现金流:'+NUMTOSTRN(每股现金流,2)+'元'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(15,50,'主收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,COLORYELLOW;
DRAWTEXTABS(15,65,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(15,80,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),COLORYELLOW;
DRAWTEXTABS(160,80,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),COLORYELLOW;
DRAWTEXTABS(15,95,'资产负债率:'+NUMTOSTRN(资产负债率,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(160,95,'每股市净率:'+每股市净率+'倍 '),LINETHICK1,COLOR00FF00;
A4:=MA(CLOSE,20);
A5:=(CLOSE MA(CLOSE,5));
A6:=(MA(CLOSE,5) MA(CLOSE,10));
A7:=(CLOSE MA(CLOSE,10));
A8:=(MA(CLOSE,5) MA(CLOSE,20));
A9:=(CLOSE MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
阻力位:=IF((CLOSE 200),(CLOSE * 1.01),(CLOSE * 1.07));
阻力位1:=IF((CLOSE 10),(CLOSE * 1.05),阻力位);
止损位:=IF((CLOSE 200),(CLOSE * 0.99),(CLOSE * 0.93));
止损位1:=IF((CLOSE 10),(CLOSE * 0.95),止损位);
TJTS1:=BARSTATUS=2 and c
TJTS2:=BARSTATUS=2 and c
k2:=hhv(h,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 = V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。      '),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。      '),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。      '),ALIGN2,colorDC143C;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 = V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。      '),ALIGN2,color0000FF;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 = V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 = V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股放量下跌,走势明显偏弱,离场观望。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股缩量下跌,走势偏弱,离场观望。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股形态良好,强势明显,量能充足,可以继续持有。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股走势趋弱,量能不足,减持大部分筹码。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股形态不佳,注意成交量的变化,但目前不适合参与。      '),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) ,k2*0.99,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。      '),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股有走强迹象,但量能不足,趋势不明,不适合操作。      '),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) ,k2*0.99,'该股走势太弱,没有参与价值。      '),ALIGN2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 = V2)) ,k2*0.99,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右,      '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 = V2)) ,k2*0.98,' 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。      '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 V2)) ,k2*0.99,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌,      '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 V2)) ,k2*0.98,' 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。      '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 = V2)) ,k2*0.99,'大盘形态走坏,重仓者可以减去大部分仓位。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 V2)) ,k2*0.99,'大盘缩量调整,注意风险,短线清仓观望。      '),ALIGN2,color00FF00;
DRAWTEXT(TJTS2 and (((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) ,k2*0.99,'大盘走势良好,量能理想,可以继续持有强势股。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) ,k2*0.99,'大盘形态良好,但量能稍显不足,随时准备减仓。      '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) ,k2*0.99,'大盘趋势不明,注意成交量变化,目前不适宜进场。      '),ALIGN2;
N:=20;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
量能饱和度:=IF(SAT 1,1,SAT)*100;市净率:=DYNAINFO(58);
DRAWTEXTABS(15,120,'量能饱和度:'+NUMTOSTRN(量能饱和度,2)+'%'),LINETHICK1,COLORFF50FF;
DRAWRECTREL(0,85,15,380,RGB(30,30,30)),COLORWHITE;
AAA:=量能饱和度
BBB:=量能饱和度 10 AND 量能饱和度
CCC:=量能饱和度 20 AND 量能饱和度
DDD:=量能饱和度 30 AND 量能饱和度
EEE:=量能饱和度 50 AND 量能饱和度
FFF:=量能饱和度 70 AND 量能饱和度
GGG:=量能饱和度 80 AND 量能饱和度
HHH:=量能饱和度
IF BARSTATUS=2 AND AAA THEN BEGIN DRAWRECTREL(0,350,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND BBB THEN BEGIN DRAWRECTREL(0,320,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND CCC THEN BEGIN DRAWRECTREL(0,290,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND DDD THEN BEGIN DRAWRECTREL(0,230,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND EEE THEN BEGIN DRAWRECTREL(0,170,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND FFF THEN BEGIN DRAWRECTREL(0,140,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND GGG THEN BEGIN DRAWRECTREL(0,110,15,380,RGB(255,0,0));
END
ELSE
IF BARSTATUS=2 AND HHH THEN BEGIN DRAWRECTREL(0,85,15,380,RGB(255,0,0));
END;
W:=BARSLAST(DISPSTATUS=1);
低涨:(H/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
高跌:(L/HHV(HIGH,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天日:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
天:BARSLAST(H=HHV(HIGH,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
{以下设置提示文字部分}
DRAWTEXTREL(15,480,'■低点至今日最高点上涨:'+NUMTOSTRN(低涨,2)+'% '+NUMTOSTRN(天日,0)+'天'),COLORFF50FF;
DRAWTEXTREL(15,550,'■高点至今日最低点下跌:'+NUMTOSTRN(高跌,2)+'% '+NUMTOSTRN(天,0)+'天'),COLORFF50FF;
DRAWTEXTREL(15,620,'■目前可见K线:'+NUMTOSTRN(W+1,0)+'天'),COLOR00FF00;

鲜花

握手

雷人

路过

鸡蛋
雪球

Powered by Discuz! X3.4 © 2001-2012 Comsenz Inc. Designed by 999test.cn & 雪球

GMT+8, 2021-3-6 05:47 , Processed in 0.115978 second(s), 17 queries .

返回顶部