找回密码
雪球 门户 银行贷款 查看内容

【股票价格计算】【图】股票价值公式

2021-2-22 21:26| 发布者: admin| 查看: 2| 评论: 0

摘要: 水平面:MA(CLOSE,89),COLORFFA2FF; BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4; IF(BBI REF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2; IF(BBI REF(BBI,1),BBI,DRAWNULL),COLORYELLOW,LINETHICK ...
水平面:MA(CLOSE,89),COLORFFA2FF;
BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4;
IF(BBI REF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2;
IF(BBI REF(BBI,1),BBI,DRAWNULL),COLORYELLOW,LINETHICK2;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2 =1,O,C,2.5,0),COLORYELLOW;
T12:=V2
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2 =1,3) OR REF(V2 =1,2) OR REF(V2 =1,1)) AND
((L10 L1 AND L20 H1) OR (L11 L1 AND L21 H1) OR (L H1));
T11:=T111 AND REF(T111,1)=0;
STICKLINE(T11,O,C,2.5,0),COLORFF00FF;
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
A1:=MIN(O,C);
B1:=ABS(O-C);
T1:=FILTER(BB13 1 AND EMA(X1,13) REF(EMA(X1,8),1),10);
STICKLINE(T1,A1,A1+B1/2,2.5,0),COLOR007575;
STICKLINE(T1,A1+B1/2,A1+B1,2.5,0),COLORBLUE;
STICKLINE(T11 AND T12,A1,A1+B1/2,2.5,0),COLORFF00FF;
STICKLINE(T11 AND T12,A1+B1/2,A1+B1,2.5,0),COLORYELLOW;
STICKLINE(T1 AND T12,A1+B1/3,A1+B1,2.5,0),COLORYELLOW;
STICKLINE(T1 AND T12,A1,A1+B1/3,2.5,0),COLOR007575;
STICKLINE(T1 AND T12,A1+B1/3,A1+B1*2/3,2.5,0),COLORBLUE;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
{DRAWTEXT(CROSS(FF,MA15),(LOW * 0.97),'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),'顶背离'),COLOR1880FF;}
STICKLINE(CROSS(FF,MA15),A1,A1+B1/2,2.5,0),COLOR7F017F;
STICKLINE(CROSS(88,RSI),A1+B1,A1+B1/2,2.5,0),COLORGREEN;
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),POINTDOT,LINETHICK2,COLORWHITE;
%19.8:REFDATE(H19,DATE),POINTDOT,LINETHICK2,COLORYELLOW;
%38.2:REFDATE(H38,DATE),POINTDOT,LINETHICK2,COLORGREEN;
%50:REFDATE(H中,DATE),POINTDOT,LINETHICK2,COLORRED;
%61.8:REFDATE(H61,DATE),POINTDOT,LINETHICK2,COLORMAGENTA;
%80.9:REFDATE(H80,DATE),POINTDOT,LINETHICK2,COLORBLUE;
低点:REFDATE(低,DATE),POINTDOT,LINETHICK2,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;

鲜花

握手

雷人

路过

鸡蛋
雪球

Powered by Discuz! X3.4 © 2001-2012 Comsenz Inc. Designed by 999test.cn & 雪球

GMT+8, 2021-2-28 03:04 , Processed in 0.125309 second(s), 17 queries .

返回顶部