找回密码
雪球 门户 银行贷款 查看内容

【ddy指标】【图】通用版DDY和DDZ指标源码

2021-2-23 14:07| 发布者: admin| 查看: 2| 评论: 0

摘要: CC:=IF(AA AND BB,0,VOL/3); DDY:3*(AA-(BB+CC))/IF(CAPITAL 1,SUM(INDEXV,71),CAPITAL),LINETHICK0; STICKLINE(DDY 0,0,DDY,2.5,0 ),COLORRED; STICKLINE(DDY 0,0,DDY,2.5,0 ),COLORGREEN; DDY1:EMA(DDY,60)*60,C ...
CC:=IF(AA AND BB,0,VOL/3);
DDY:3*(AA-(BB+CC))/IF(CAPITAL 1,SUM(INDEXV,71),CAPITAL),LINETHICK0;
STICKLINE(DDY 0,0,DDY,2.5,0 ),COLORRED;
STICKLINE(DDY 0,0,DDY,2.5,0 ),COLORGREEN;
DDY1:EMA(DDY,60)*60,COLOR00FFFF;
DDY2:MA(DDY1,5),COLORFF00FF;
DDY3:MA(DDY1,10),COLOR00FF00;
预警:DDY 0 AND CROSS(DDY1,DDY3) AND (CLOSE/REF(CLOSE,1)-1)
*100 3,LINETHICK0;
DRAWTEXT(预警,0,'★'),LINETHICK3,COLOR00FFFF;
{DRAWTEXT(C 0,0,'涨跌动因'),COLORFFFFFF;};
-------------------------------------------------------------------------------------------------------------
DDZ:
JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
QJ5:=QJ1+QJ2;QJ6:=QJ3+QJ4;DD:=(QJ5-QJ6)/(QJ5+QJ6)*100;
DDZ:DD*17,LINETHICK1;
DDZ1:DD*13,LINETHICK1;
DRAWBAND(DDZ1,RGB(0,24,224),DDZ,RGB(255,0,0));
-----------------------------------------------------------------------------------------------------------------
指标用法:
ddx大单动向:
大单动向基于大智慧Level-2逐单分析功能,是一个短中线兼顾的技术指标。
DDX红绿柱线表示当日大单买入净量占流通盘的百分比(估计值),红柱表示大单买入量较大,绿柱表示大单卖出量较大,DDX1是大单买入净量60日(参数p1)平滑累加值占流通盘比例,DDX2和DDX3是其5日(参数p2)和10日(参数p3)移动平均线。
用法:
(1)如果当日红绿柱线为红色表示当日大单买入量较大,反之如果当日红绿柱线为绿色表示大单卖出较多。
(2)3线持续向上主力买入积极,股价有持续的上涨动力。
(3)3线持续向下表示主力持续卖出。
(4)可以在动态显示牌中对DDX由大到小排序选出短线强势股。
ddy涨跌动因:
涨跌动因指标基于大智慧新一代的逐单分析,逐单分析是对交易委托单的分析,涨跌动因是每日卖出单数和买入单数差的累计值。
DDY红绿柱线是每日卖出单数和买入单数的差占持仓人数的比例(估算值),DDY1是单数差的60日平滑累加值(参数P1可调),DDY2是DDY1的5日和10日均线。
用法:
(1)如果当日红绿柱线为红色表示当日单数差为正,大单买入较多,反之如果当日红绿柱线为绿色表示当日单数差为负,大单卖出较多。
(3)3线持续向上则表示筹码在持续向少数人转移,有主力资金收集,股价有持续的上涨动力。
(4)股价上涨3线却向下,表明是游资短线和散户行情,一般不具备长期的上涨动力。
(5)涨跌动因指标所要在一个较长的周期内观察,如果一段时间3线持续向上,那么每次股价回调就是买入良机。
相反如果上涨时3线持续向下,那么短线超买就是减仓良机。
(6)一般的,在0轴以上说明长期的累积值是趋向搜集,0轴以下说明长期的累积值是发散。
(7) 涨跌动因 指标具有极大的超前性,因为筹码的收集和发散都有一个过程。股价尽管还沿着原来的趋势运行,但筹码转移的方向已经逆转。
(8)可以在动态显示牌中对DDY由大到小排序选出短线强势股。
ddz大单差分:
红色彩带表示了大资金买入强度,色带越宽、越高表示买入强度越大。当彩带突然升高放宽时往往预示短线将快速上涨。
在动态显示牌下对该指标排序可以选出短线强势股
[ 本帖最后由 小明1022 于 2009-6-3 18:47 编辑 ] 相关标签: 炒股公式, 股票公式, 股票, 选股公式, 股票指标

鲜花

握手

雷人

路过

鸡蛋
雪球

Powered by Discuz! X3.4 © 2001-2012 Comsenz Inc. Designed by 999test.cn & 雪球

GMT+8, 2021-3-6 01:16 , Processed in 0.133245 second(s), 17 queries .

返回顶部