找回密码
雪球 门户 银行贷款 查看内容

【表格中间的线怎么去掉】【图】求助老师:如何将副图中的线去掉?谢谢

2021-2-23 14:32| 发布者: admin| 查看: 1| 评论: 0

摘要: 求助老师将副图标注的线去掉,我从公式中找了很长时间,也没找到。谢谢,公式源码及图如下: MA(CLOSE,12)-EMA(CLOSE,26); DIFF:EMA(CLOSE,12)-EMA(CLOSE,26); DEA:EMA(DIFF,9); MACD:2*(DIFF-DEA),COLORSTICK; STIC ...
求助老师将副图标注线去掉,我从公式中找了很长时间,也没找到。谢谢,公式源码及图如下:
MA(CLOSE,12)-EMA(CLOSE,26);
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
STICKLINE(MACD REF(MACD,1) AND MACD 0,0,MACD,0,0),COLORGREEN;   {画柱状线}
STICKLINE(MACD REF(MACD,1) AND MACD 0,0,MACD,0,0),COLORMAGENTA; {画柱状线}
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA =0));           {统计上次DEA在0轴之上金叉至今的周期赋值}
金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=1,22)=1;     {0轴之下1次金叉赋值}     
STICKLINE(金叉,0,0.1,5,0),COLOR0000FF;                 {画柱状线}
DRAWTEXT(金叉,-0.095,'金叉'),COLOR0000FF;               {书写“金叉”}
二金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=2,22)=1;    {0轴之下2次金叉赋值}
STICKLINE(二金叉,0,0.15,5,0),COLORLIRED;                 {画柱状线}
DRAWTEXT(二金叉,0.23,'二次金叉'),COLORLIRED;             {书写“二次金叉”}     
三金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=3,22)=1;
STICKLINE(三金叉,0,0.2,5,0),COLORLIGREEN;
DRAWTEXT(三金叉,0.28,'三次金叉'),COLORLIGREEN;
四金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=4,28)=1;
STICKLINE(四金叉,0,0.25,5,0),COLORCYAN;
DRAWTEXT(四金叉,0.33,'四次金叉'),COLORCYAN;
五金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=5,28)=1;
STICKLINE(五金叉,0,0.3,5,0),COLORBLUE;
DRAWTEXT(五金叉,0.37,'五次金叉'),COLORBLUE;
六金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=6,33)=1;
STICKLINE(六金叉,0,0.35,5,0),COLORYELLOW;
DRAWTEXT(六金叉,0.0.7,'黄金底'),COLORYELLOW;
DRAWTEXT(六金叉,0.42,'六次金叉'),COLORYELLOW;
七金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=7,33)=1;
STICKLINE(七金叉,0,0.4,5,0),COLORWHITE;
DRAWTEXT(七金叉,0.0.88,'白金底'),COLORWHITE;
DRAWTEXT(七金叉,0.47,'七次金叉'),COLORWHITE;
八金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=8,33)=1;
STICKLINE(八金叉,0,0.5,5,0),COLORMAGENTA;
DRAWTEXT(八金叉,0.0.8,'钻石底'),COLORMAGENTA;
DRAWTEXT(八金叉,0.57,'八次金叉'),COLORMAGENTA;
九金叉:=CROSS(DIFF,DEA) AND DEA 0 AND COUNT(JCCOUNT=9,33)=1;
STICKLINE(九金叉,0,0.55,5,0),COLORRED;
DRAWTEXT(九金叉,0.0.8,'金钻底'),COLORRED;
DRAWTEXT(九金叉,0.6,'九次金叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));                   {上一次金叉成立至今的周期}
底背离:={(REF(L,A1+1) L) OR} REF(C,A1+1) C AND DIFF REF(DIFF,A1+1) AND CROSS(DIFF,DEA);{底背离条件}
STICKLINE(底背离,0,-0.1,5,0),COLORRED;                 {底背离柱状线}
DRAWTEXT(底背离,DEA,'底背离')COLORRED;                 {显示“底背离”}
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLOR0000FF,LINETHICK3;       {底背离画线}
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));                   {上一次死叉成立至今的周期}
顶背离:=REF(C,A2+1) C {OR REF(H,A2+1) H)} AND REF(DIFF,A2+1) DIFF AND CROSS(DEA,DIFF);{顶背离条件}
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK3;        {顶背离划线}
STICKLINE(顶背离,0,0.1,5,0),COLORGREEN;                  {顶背离柱状线}
DRAWTEXT(顶背离,DEA,'顶背离')COLORGREEN;                 {显示“顶背离”}
DRAWTEXT(CROSS(DIFF,DEA) AND 二金叉 AND 底背离,0.3,'三全底'),COLOR0000FF;{显示“三全底”}
IF(DIFF DEA,DIFF,DRAWNULL),COLORWHITE,LINETHICK2;           {当DIFF DEA时画白色粗线}
IF(DEA REF(DEA,1) AND DIFF DEA,DEA,DRAWNULL),COLORYELLOW,LINETHICK2;{当DEA DIFF时画黄色粗};如果互助答疑不能解决需求,可以到《威客任务》发布有偿悬赏。

鲜花

握手

雷人

路过

鸡蛋
雪球

Powered by Discuz! X3.4 © 2001-2012 Comsenz Inc. Designed by 999test.cn & 雪球

GMT+8, 2021-3-7 09:41 , Processed in 0.159825 second(s), 17 queries .

返回顶部